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1. Getting started
The instructions are written for OpenOffice.org but should also work for LibreOffice.

http://www.docarch.be
http://www.docarch.be
http://www.gnu.org/licenses
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1.1. Installation
In order to install odt2braille, OpenOffice.org version 3.1 or later is required. You can find the latest
version of OpenOffice.org at http://download.openoffice.org/other.html. If you don't have Java installed
on your system (verify your Java version at http://www.java.com/en/download/installed.jsp), make sure
you include the Java Runtime Environment (JRE) to the download. Java 1.6 is required. If you choose
not to download OpenOffice.org with Java you can easily install Java afterwards. You can get the latest
version from http://java.com/en/.

To add the odt2braille extension, launch OpenOffice.org and open Tools > Extension Manager….
First remove any older versions of odt2braille. Then choose Add…, select the odt2brailleinstallation
package and follow the steps. You can download the latest version from http://odt2braille.sourceforge.net/
downloads.html.

Note

Make sure the installation package is an .oxt file. It might happen that Internet Explorer saves it
as a .zip file. In this case, just rename the file back to .oxt.

It is strongly recommended that you also download and install the odt2braille fonts: http://
odt2braille.svn.sourceforge.net/viewvc/odt2braille/trunk/fonts/odt2braille6.ttf for 6-dot Braille and http://
odt2braille.svn.sourceforge.net/viewvc/odt2braille/trunk/fonts/odt2braille8.ttf for 8-dot Braille.

Note

Make sure you install the fonts after the plugin has been installed. Doing it the other way around
may cause the Braille preview window to show a bunch of meaningless squares or periods instead
of Braille symbols.

Finally, when everything is installed, restart OpenOffice.org and you're ready to go.

1.2. OpenOffice.org and LibreOffice Accessibility
OpenOffice.org and LibreOffice are poorly accessible with traditional screen readers on Windows.
Accessing these office suites with the newer screen reader NVDA (NonVisual Desktop Access
http://www.nvda-project.org/) appears to work better. Mac OS users can access OpenOffice.org with
VoiceOver (http://www.apple.com/accessibility/voiceover/); Linux users can access itwith Orca (http://
live.gnome.org/Orca). (Some screen readers may provide good access to the user interface but not to
document content, for example, the text alternative for an image.) However, access to OpenOffice.org or
LibreOffice does not necessarily imply that the user interface of an extension is accessible in the same way.
The odt2braille project would greatly appreciate any feedback about the accessibility of the extension (with
information on which OpenOffice.org/LibreOffice version, which screen reader version, which operating
system, etcetera you use the extension).

1.3. Introduction
This guide explains how to create a document in OpenOffice.org Writer and prepare it for Braille
production. You can find more help on working with Writer at http://wiki.services.openoffice.org/wiki/
Documentation/OOo3_User_Guides/Writer_Guide.

After installing odt2braille, a whole new range of user preferences will become available. Because of the
broad range of Braille formatting conventions in use worldwide, odt2braille provides a lot of flexibility.
Users are able to adjust the Braille layout in detail, just like they can fully customize the print layout.

http://download.openoffice.org/other.html
http://www.java.com/en/download/installed.jsp
http://java.com/en/
http://odt2braille.sourceforge.net/downloads.html
http://odt2braille.sourceforge.net/downloads.html
http://odt2braille.svn.sourceforge.net/viewvc/odt2braille/trunk/fonts/odt2braille6.ttf
http://odt2braille.svn.sourceforge.net/viewvc/odt2braille/trunk/fonts/odt2braille6.ttf
http://odt2braille.svn.sourceforge.net/viewvc/odt2braille/trunk/fonts/odt2braille8.ttf
http://odt2braille.svn.sourceforge.net/viewvc/odt2braille/trunk/fonts/odt2braille8.ttf
http://www.nvda-project.org/
http://www.apple.com/accessibility/voiceover/
http://live.gnome.org/Orca
http://live.gnome.org/Orca
http://wiki.services.openoffice.org/wiki/Documentation/OOo3_User_Guides/Writer_Guide
http://wiki.services.openoffice.org/wiki/Documentation/OOo3_User_Guides/Writer_Guide
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To make sure that non-technical users will not be overwhelmed with possibilities, they have the option to
choose from a series of formal Braille rules, e.g. the BANA principles of print to Braille transcription (see
http://www.brl.org/formats/). This will considerably limit their freedom, but it will also greatly simplify
the production of valid and well-formatted Braille.

What follows next is a detailed overview of all possibilities odt2braille offers.

2. Authoring Braille

2.1. Languages
• OpenOffice.org allows you to write documents in various languages or mix multiple languages within

the same document. You can set the language for the whole document, individual paragraphs, or even
individual words and characters. The language tools can be found in Tools > Languages.

• Languages can be associated with Braille translation tables in Format > Braille…. The translation table
for the whole document can be set with the main language option on the General tab. A contraction
level can also be chosen. If the document contains multiple languages, each additional language can be
linked to a translation table and contraction level in the Languages tab.

• Translation tables are available for all Western European languages, Modern Hebrew, some Asian
languages and even some minority languages like Gaelic and Esperanto.

2.2. Paragraphs
• In OpenOffice.org, all regular text between ¶ markers is considered a paragraph (¶ markers can be made

visible by selecting View > Nonprinting Characters).

• Each paragraph has got a formatting style. Paragraph styles can be assigned and modified in Format >
Styles and Formatting (F11).

• All paragraphs will be transcribed as Braille paragraphs, except headings, captions and paragraphs inside
a list, inside a table or inside a note.

• By default, paragraphs are rendered in indented paragraph style (first line cell 3, runovers cell 1 and
not separated by blank lines.

• Paragraph settings can be altered in Format > Braille > Paragraphs. You can link each used paragraph
style with a different Braille formatting style.

• Braille formatting settings for paragraphs include spacing, alignment and margins. You can control how
many lines of a paragraph must be printed at least at the bottom of a page (Orphan control). Moreover,
you can protect a paragraph from being split across multiple pages (Don't split), and you can keep a
paragraph together with the first line of the next (Keep with next).

• By default, empty paragraphs are dropped in the Braille edition. By checking the option Keep empty
paragraphs, an empty paragraph is brailled as an empty line.

2.3. Headings
• In order for a paragraph to be interpreted by odt2braille as a heading, following conditions must be true:

• An outline level has to be assigned to the paragraph. This can be achieved in two ways:

• Outline levels can be permanently linked to paragraph styles in Tools > Outline Numbering.

http://www.brl.org/formats/
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• If no outline level is linked to the current paragraph style, a level can still be assigned to the text
by setting Outline Level in Format > Paragraph > Outline & Numbering.

By default, the paragraph styles Heading 1, Heading 2, etc. have outline levels 1, 2, etc. The navigator
View > Navigator (F5) provides an overview of all headings in a document and the outline levels.

• In addition, the paragraph should not be placed inside a list, table or note.

• To enable automatic numbering or bulleting of headings, set Numbering Style (Format > Paragraph >
Outline & Numbering) to Outline Numbering.

• The exact formatting of bullets and numbers can be determined in Tools - Outline Numbering.
Alternatively, choose Format > Bullets & Numbering when a heading has the cursor.

• In Braille, headings are rendered as follows:

• Level 1 headings are centered and preceded and followed by a blank line.

• Level 2 headings are centered as well but are only preceded by a blank line.

• Level 3 headings begin in cell 5 (runovers too) and are preceded by a blank line.

• Headings with an outline level greater than 3 begin in cell 1 (runovers too) and are preceded by a
blank line.

All these settings can be altered in Format > Braille > Headings.

• As with paragraphs, you can set spacing, alignment and margins, you can protect a heading from being
split across multiple pages, and you can keep a heading together with the first line of the following
heading or paragraph.

• In addition, you can make a heading start on a new page.

• Numbers of headings are completely adopted in Braille.

• Bullets inside headings are automatically removed.

• Empty headings are automatically removed.

• All special typeface in a heading is ignored.

• Only headings inside the body of the document (not in the frontmatter) are included in the table of
contents.

• Footnotes in headings: see Notes.

• When a regular volume doesn't start with a heading, odt2braille inserts a continuation heading: the
closest preceding heading is repeated and suffixed with the string "(Cont.)". This continuation
heading is included in the table of contents as well.

Tip

Always start a volume with a heading.

2.4. Lists
• Each paragraph with a Numbering Style Format > Paragraph > Outline & Numbering that is not Outline

Numbering or None, will be interpreted by odt2braille as an item of a list.
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• To produce a numbered or bulleted list in OpenOffice.org, either use the numbering and bullets icons,
or use list styles.

• The numbering and bullets icons can be found on the Formatting toolbar View > Toolbars >
Formatting or the Bullets and Numbering toolbar View > Toolbars > Bullets and Numbering.

• List styles can be selected in Format > Styles and Formatting > List Styles. When creating a new list
style, make sure the name is not of the form L1 / L2 / …

• The level of a list item can be modified with keyboard shortcuts (tab to move down a level, shift + tab
to move up a level) or with the Bullets and Numbering toolbar.

• The exact formatting of lists can be determined in Format > Bullets and Numbering. Alternatively, if
the list was created using list styles Format > Styles and Formatting > List Styles, right click on the
list style and choose Modify.

• All Braille formatting settings for lists can be altered in Format > Braille > Lists.

• By default, lists are brailled as follows:

• Level 1 list items begin in cell 1, runovers begin in cell 5.

• Level 2 list items begin in cell 3, runovers in cell 7.

• Level 3 list items begin in cell 5, runovers in cell 9.

• List items with an outline level greater than 3 begin in cell 7, runovers in cell 11.

The entire list is preceded and following by a blank line.

• Numbers of list items are completely adopted in Braille.

• The user can determine how bullets are brailled.

• List items or entire lists can be protected from being split across pages.

• Textboxes and images that are anchored to a list item are rendered only after completion of the entire list.

2.5. Tables
• In OpenOffice.org, tables are created with Table > Insert > Table or Insert > Table or with the Table

toolbar View > Toolbars > Table.

• The first row(s) of a table can be defined as column headings by checking the Headings box.

• To add a caption to the table, place the cursor inside the table and choose Insert > Caption. In order for
a table caption to be correctly linked to the table, it must be placed directly beneath the table.

• In Braille, tables are by default rendered in stairstep format:

• Column 1 table cells begin in cell 1, runovers too.

• Column 2 table cells begin in cell 3, runovers too.

• …

• Table cells in column 10 and beyond begin in cell 19.
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• However, is it also possible to render tables in linear format. In this case, all cells in a table row are
joined together. The user can choose the column delimiter symbol which separates the cells.

• Table rows can be protected from being split across Braille pages.

• All table settings can be accessed in Format > Braille > Tables.

• Only regular text is retained in a table cell, all other elements are dropped or transposed. If a table cell
contains multiple paragraphs, these are first serialized.

• Table lines are only shown in Braille if they are present in print. A table line is represented by a series
of unspaced Braille dots 2356 (top table line) or 1245 (bottom table line), extended across the full width
of the Braille page. A table inside a larger textbox is enclosed by full table lines (Braille dots 123456).
If no table lines are shown in print, the table is preceded and/or followed by a blank line.

• If column headings are present, these table rows are separated from the table body by a series of unspaced
Braille dots 25, extended across the full width of the Braille page.

• If a caption is correctly linked to the table, it is centered and placed directly below the top table line
(or top blank line if the table line is absent). A blank line is inserted between the caption and the actual
table content.

• All footnotes are collected beneath the table body, but above the bottom table line (or bottom blank line
if the table line is absent). Footnotes in the table caption are placed directly below the caption.

• Empty table cells are indicated with an ellipsis (Braille dots 5-5-5).

• When a table contains other tables, lists, textboxes or images, these elements are moved outside the table.
Every transposition is indicated by a double dash (Braille dots 36-36-36-36) at the element's original
location. An explaining transcriber's note is inserted before the table. Only after completion of the entire
table, all previously omitted material is rendered. Each element is preceded by another transcriber's note
explaining it was moved from it's original location.

Tip

Do not place other tables, lists, textboxes or images inside a table.

• A merged table cell is processed as if its whole content were in the left- and uppermost 'sub'-cell. The
other (empty) 'sub'-cells are not shown in Braille. (This currently also applies to right-to-left writing
systems such as Hebrew.)

Tip

Try to avoid merged cells.

2.6. Textboxes
• In OpenOffice.org, textboxes can be produced by choosing Insert > Frame. Options can be modified

later in Format > Frame/Object. On the Type tab, the anchor type can be selected. The anchor is the
basis of the position and behavior of the textbox within a document. It makes the textbox move with
the object it is anchored to. You can anchor frames as a character or to a page, paragraph, or character.
In addition, if a textbox has been placed inside another textbox, it can be anchored to this outer frame.
The anchor is symbolized by a gray marker, which is only visible if the textbox is selected.

• To add a caption to the textbox, place the cursor inside the textbox and choose Insert > Caption. In order
for a caption to be correctly linked to the textbox by odt2braille, one of the following must be true:
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• The textbox is anchored to a caption.

• The paragraph immediately following the object the textbox is anchored to is a caption, and no other
frame (i.e. textbox or image) is anchored to it.

• The last paragraph of the textbox is a caption and no other frame is anchored to it.

A caption that has been inserted through Insert > Caption is automatically linked to the textbox.

• If textboxes are anchored as a character or to a paragraph or character, they are rendered in Braille after
completion of the paragraph or heading that contains the anchor.

• If textboxes are anchored to another textbox, they are rendered inside this outer textbox, before any
other material it contains.

• Textboxes are omitted in Braille if they are anchored to a page.

• Textboxes that are anchored to a list item are rendered only after completion of the entire list.

• Textboxes that are anchored to a table cell are rendered only after completion of the entire table.

• Textboxes that are anchored to a note are replaced by a double dash (Braille dots 36-36-36-36),
indicating the omission.

• Box lines are only shown in Braille if they are present in print. A box line is represented by a series of
unspaced Braille dots 2356 (top table line) or 1245 (bottom table line), extended across the full width
of the Braille page. If no box lines are shown in print, the textbox is preceded and/or followed by a
blank line.

• If a caption is correctly linked to the textbox, it is centered and placed directly below the top box line
(or top blank line if the box line is absent). A blank line is inserted between the caption and the actual
content of the box.

• All material inside a textbox is retained in Braille. Headings are included in the table of contents.

2.7. Images
• In OpenOffice.org, images can be inserted by choosing Insert > Picture. Options can be modified later

in Format > Picture. Like textboxes, an image can be anchored as a character or to a page, paragraph,
character, or frame.

• To add a caption to the image, select the image and choose Insert > Caption. In order for a caption to
be correctly linked to the image by odt2braille, one of the following must be true:

• The image is anchored to a caption (Anchored to paragraph, to character or as character).

• The paragraph immediately following the object the image is anchored to is a caption, and no other
frame (i.e. textbox or image) is anchored to it.

A caption that has been inserted through Insert > Caption is automatically linked to the image.

• For each image, a title and/or description can be provided in Format > Object > Description.
Alternatively, the title can be set with the Alternative (Text only) field in Format > Picture > Options.

Tip

The image description should be as brief and concise as possible.
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Note

OpenOffice 3.2 and older versions have a bug that deletes an image’s text alternatives (Title
and Description) if the anchor is modified or when a caption is added. To avoid this, the text
alternatives should be added after modifying the anchor or after adding a caption.

• In Braille, images are replaced by a transcriber's note, which includes

1. The image caption (if one is correctly linked to the image).

2. The image title (if one is defined).

3. An alternative desciption (if one is defined).

• If images are anchored as a character or to a paragraph or character, they are rendered in Braille after
completion of the paragraph or heading that contains the anchor.

• If images are anchored to a textbox, they are rendered inside this textbox, before any other material
it contains.

• Images are omitted in Braille if they are anchored to a page.

• Images that are anchored to a list item are rendered only after completion of the entire list.

• Images that are anchored to a table cell are rendered only after completion of the entire table.

• Images that are anchored to a note are replaced by a double dash (Braille dots 36-36-36-36), indicating
the omission.

2.8. Captions
• To add a caption to an object in OpenOffice.org, select this object and choose Insert > Caption.

odt2braille treats all text (with the exception of headings) with a paragraph styles Caption, Table,
Drawing, Illustration or Text as captions.

You can also add your own caption style by right-clicking on one of the above styles and choosing New.

• A caption is only rendered in Braille if odt2braille links the caption to an object. Captions can be linked
to tables, textboxes or images. For more details on the linking of captions to objects, see the appropriate
sections.

• Table captions and textbox sections are centered and placed directly below the top table/textbox line
(or top blank line if the table/textbox line is absent). A blank line is inserted between the caption and
the actual table/textbox content. Image captions are contained in the transcriber's note that represents
the image.

• Footnotes in captions: see Notes.

2.9. Notes
• To insert a note in an OpenOffice.org document, put the cursor where you want the note reference

marker to appear, then select Insert > Footnote/Endnote. Footnotes are displayed at the bottom of the
page containing their corresponding reference. By default, endnotes are collected at the end of the entire
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document. To collect endnotes at the end of the OpenOffice.org section that contains the note reference,
choose Format > Sections, select a section, choose Options > Footnotes/Endnotes and check the option
Collect at end of section. Sections can be inserted by choosing Insert > Section.

• In Braille, note references are preceded by the unspaced reference indicator (Braille dots 35-35) and a
number indicator (in case of a number) or a letter indicator (in case of a letter). References are separated
from surrounding text by at least one blank cell.

• No blank lines are left before, after or between notes.

• Only regular text is retained inside a note, all other elements are dropped. If the note contains multiple
paragraphs, these are first serialized. Every omission of an element is indicated by a double dash (Braille
dots 36-36-36-36) at the element's original location.

• Footnotes begin in cell 7, runovers begin in cell 5. Footnotes in paragraphs, headings, captions and list
items are rendered immediately below the paragraph, heading, caption or list item. Footnotes in tables
are are collected beneath the table body, but above the bottom table line (or bottom blank line if the
table line is absent).

• Endnotes are collected in note sections. Each note section begins on a new page. The fully capitalized
heading ("NOTES") is formatted as a level 1 heading. This heading is not included in the table of
contents. Then the endnotes are listed, ordered by their appearance in print. Each endnote begins in cell
1, runovers begin in cell 3. When the note section is complete, subsequent text is resumed on a new page.

• Note sections can appear at various places in the Braille document:

• If an endnote is contained in an OpenOffice.org section that has the Collect at end of section option
checked, the note is brailled accordingly at the end of that section.

• Endnotes that are contained in the frontmatter are placed at the end of the frontmatter.

• All remaining endnotes are collected at the end of their volume.

2.10. Special Typeface
• In OpenOffice.org, you can apply many formats to characters using the Format > Character… window

and the buttons on the Formatting toolbar (View > Toolbars > Formatting). Text can also be formatted
by applying a character style (Format > Styles and Formatting > Character Styles).

• The relevant options for odt2braille are Bold, Italic, Underline and (Small) Capitals.

• Braille formatting settings for characters can be altered in Format > Braille > Special Typeface. The
user can link each used character style with a different Braille formatting style. Bold, Italic, Underline
and Capitals can be ignored in Braille, but by default the print version in followed.

• All special typeface in headings is ignored in the Braille edition.

2.11. Page Numbering
• To add a page number, put the cursor where you want the number to appear, then select Insert > Fields

> Page Number. If you want to number all your pages automatically, insert a page number in the page
header Insert > Header > Default or page footer Insert > Footer > Default.

• odt2braille will only proces the first page number in a header or footer (in that order).
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• All pages of text in the Braille edition carry consecutive Braille page numbers starting with arabic 1 in
the first volume (or a higher value specified by the option Start numbering at). In subsequent volumes,
pages of text are numbered consecutively from volume to volume. Preliminary page numbers are either
prefixed by the unspaced letter p, or rendered in Roman numerals, the choice is up to the user. Each
preliminary section is numbered individually, starting with p1 or i. By default, the Braille page number
is displayed in the bottom right corner of the page, with no fewer than three blank cells left between the
text and the number. The user can also decide to place page numbers at the top, or not display them at all.

• If the source document contains page numbers, they can be included in the Braille version as well.
By default, print page numbers are displayed in the top right corner of each Braille page (except on
preliminary pages), again with no fewer than three blank cells left between the text and the number.
The number can also be placed at the bottom. When print page numbers and Braille page numbers are
both placed at the top or bottom, they are rendered next to each other, print number first, with a space
in between.

• If material on a print page cannot be contained on a single Braille page and must be continued on one
or more pages, the same print page number is placed in the top right corner of each of these pages. The
number is prefixed by the unspaced letter a (brailled without the letter indicator) for the first continued
page, the letter b for the second, etc.

• Optionally, the user can decide to display the range of print pages contained in a Braille page (instead
of only the page number of the first print page). If the first page in this range is a continued print page,
it is prefixed with a letter as usual.

• When a new print page begins within a Braille page, a page change indicator, a line of unspaced Braille
dots 36, can be produced, with or without the new print page number placed on the same line at the right
margin. No space is left between this indicator and the first symbol of the page number.

• By default, empty pages are ignored. If this setting is disabled, a combined print page number will be
displayed whenever empty pages are encountered: the number of the first empty page is combined with
that of the page on which text reappears, e.g. 5-7. If lettered continuation pages are required, they carry
only the number of the page on which text reappears.

• Another option is to treat unnumbered print pages as if they were a part of the preceding page (as if
their was no page break).

• All page number settings can be found in Format > Braille > Page Numbers.

2.12. Preliminary Pages
Preliminary pages are those pages that precede the actual text of the document. These can include for
example a title page, a special symbols page, a transcriber's note page, cover material, about the author,
a dedication, acknowledgements, an abstract, a table of contents, author's notes, a preface, a foreword, an
introduction or a prologue, etc.

• Which content is included in the preliminary section and the order of items is totally up to the
transcriber. All frontmatter content must be placed inside a section at the beginning of the document.
In OpenOffice.org, sections can be inserted by choosing Insert > Section. An overview of all sections
the document contains and there level is provided by the navigator View > Navigator (F5). In Format
> Braille > Document Structure, you can specify which section is the preliminary section.

• The transcriber also has the option to automatically include a list of special symbols, a transcriber's note
page and a table of contents. These are at the very end of the preliminary section, before any possible
note sections.
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• Another possibility is to create a preliminary volume. This option should be checked if more than 80-90
Braille pages are required for the preliminary pages in the first volume to include all items (see Volume
Management).

• Some pages (i.e. the title page, the special symbols page, the transcriber's notes page and the table of
contents) are repeated in every Braille volume. However, their content is different for each volume. All
other pages only appear in the extended (the first) preliminary section.

• Preliminary pages are distinguished from normal pages by a different page numbering.

• The actual volume body that follows the preliminary section always starts on a new right-hand Braille
page.

2.13. Volume Management
Often, because documents are too long to be bound in one single Braille book, they are arranged in volumes.

Tip

Typically a volume should have around 80-90 one-sided pages (the page count includes all pages,
including the preliminary pages). Ideally, the next volume starts at a logical place, such as the
beginning of a new chapter. As a guideline, there should not be a difference of more than 15
pages between two volumes.

Also, appendixes, glossaries, indexes, bibliographies, etc. are often more useful when bound in separate
supplementary volumes (supplements). Finally, the extended preliminary pages are sometimes bound in a
separate preliminary volume, when the first volume would otherwise become to long.

• OpenOffice.org, by default, puts the entire document in one single volume. The document can also be
automatically split in volumes, based on a preferred number of print pages per volume.

• To manually create volumes and supplements, devide your document into sections Insert > Section. In
Format > Braille > Volume Management, you can then specify which sections belong to which volumes.

• In Braille, every volume or supplement has its own preliminary section (if enabled by the user). Both
the preliminary section and the volume body start on a new right-hand Braille page. If a preliminary
volume is created, it contains the extended preliminary pages, but no actual volume body.

• When a volume doesn't start with a heading, odt2braille automatically inserts a continuation heading:
the closest preceding heading is repeated and suffixed with the string "(Cont.)".

2.14. Title Page
• To create a title page, create a section inside of the preliminary section. In Format > Braille > Document

Structure, you can specify which section is the title page.

Tip

The title page should be the very first page.

• If a title page has been defined, the transcriber has the option to include a transcription information block.
Furthermore, if the title page is a preliminary page, a volume information block can be included as well.
These options can be found in Format > Braille > General. The Braille formatting of the blocks can be
specified by the Paragraph style fields. The name of the transcriber can be set with the Transcriber field.
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• The volume information block contains the volume identification, the total number of volumes, the page
range, etc.

Example 1. Example 1

In 9 volumes and 2 supplements

Volume 2

Braille pages p1-p16 and 1-72

Print pages 46-79

Example 2. Example 2

In 1 preliminary and 5 volumes

Preliminary volume

Braille pages p1-p81

• The transcription information block contains the transcriber's name, the year of Braille transcription, etc.

Example 3. Example

Transcribed 2010 by Bert Frees with odt2braille

2.15. List of Special Symbols
• If a preliminary section has been defined, the transcriber has the option to include a list of special

symbols in Format > Braille > Special Symbols. He or she can also decide which symbols will be shown,
in which order, under which conditions (always, only in the first volume, or only when actually used in
the current volume), and how they are described. The list heading can be modified as well. By default,
it is set to "SPECIAL SYMBOLS USED IN THIS VOLUME".

• A special symbols list is included in the preliminary pages of each volume. The actual content varies
between volumes. The special symbols list begins on a new Braille page. The heading is formatted as
a level 1 heading. It is not included in the table of contents.

• Each Braille symbol begins in cell 1 and is followed, after one blank cell, by its identifying dot numbers,
enclosed in parentheses, and its description. Runovers begin in cell 3. These are the symbols that are
listed by default:

• # (56) Letter indicator,

• # (3456) Number indicator,

• ## (35, 35) Note reference indicator,

• ## (6, 3) Transcriber's note indicator,

• # (46) Italic indicator,

• # (456) Boldface indicator,

• #### (36, 36, 36, 36) Double dash indicating an omission, and
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• ### (5, 5, 5) Ellipsis indicating empty table cell.

The exact Braille dots of some symbols can differ between languages.

• If no symbols are listed, the special symbols list is not displayed.

2.16. Transcriber's Notes
A transcriber's note is a note that is added in the Braille edition by the transcriber but not shown in the
print text. Some notes are inserted between other items in the document body, some notes are displayed
on a separate transcriber's note page in the preliminary section.

• Transcriber's notes are automatically inserted by odt2braille. A user can only control whether or not a
transcriber's note page is included in the preliminary pages, through the option Include transcriber's note
page in Format > Braille > General. The transcriber's note page heading can be modified in the field
below. By default, it is set to "TRANSCRIBER'S NOTES".

• Transcriber's notes that appear throughout the document are brailled in paragraph form. Each paragraph
of the note begins in cell 7, runovers begin in cell 5. The complete note is preceded and followed by the
unspaced transcriber's note indicator (Braille dots 6-3).

• The transcriber's note page begins on a new Braille page. The heading is formatted as a level 1 heading.
It is not included in the table of contents. Notes are brailled as indented paragraphs (first line cell 3,
runovers cell 1, no blank lines between notes). No transcriber's note indicators are used.

2.17. Table of Contents
• In OpenOffice, a table of contents can be added to the document by selecting Insert > Indexes and Tables

> Indexes and Tables and choosing Table of Contents for Type. However, these tables are not adopted
in the Braille version. Instead, users are given the option to include a table of contents in the preliminary
pages of each volume. This option is found in Format > Braille > Table of Contents. The table heading
can be modified. By default, it is set to "CONTENTS".

Tip

If a table of contents is present in print, include it in the Braille version also.

• The table of contents is rendered at the very end of the preliminary section, before any possible note
sections. The table of contents begins on a new Braille page. The heading is formatted as a level 1
heading.

• The actual content varies between volumes. On the extended (the first) preliminary pages, the table
of contents lists all headings in the entire document. Only headings in the body of the document are
included. In all other regular volumes, the table of contents is limited to headings in that particular
volume.

• Each table entry is composed of

• the heading,

• [the print page number, prefixed with the appropriate letter if the heading begins on a continued
page], and

• [the Braille page number].
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Print and Braille page numbers in the table of contents can be enabled or disabled.

• By default, level 1 headings begin in cell 1, runovers in cell 5. Level 2 headings begin in cell 3, runovers
in cell 7, etcetera. All these settings can be altered in Format > Braille > Table of Contents.

• The print and Braille page numbers are placed to end at the right margin of the Braille line on which the
heading ends. If space allows it, a sequence of unspaced guide dots, preceded and followed by a blank
cell, is inserted between the heading and the page numbers. The Braille symbol for these guide dots can
be specified by the user, the default value is Braille dots 5.

2.18. Mathematics
• To insert a mathematical expression in OpenOffice.org, go to Insert > Object > Formula. The

equation editor will open at the bottom of the screen, and the floating Selection window appears. The
equation editor uses a markup language to represent formulas. For more information on inserting math,
read the math guide at http://wiki.services.openoffice.org/wiki/Documentation/OOo3_User_Guides/
Math_Guide.

• Mathematical equations are conveyed to Braille through the use of specialized math Braille codes.
Supported math codes are Nemeth (generally accepted in the United States), Marburg (Germany), UK
Maths (United Kingdom) and Woluwe (Flanders, Belgium). You can select which code you want to use
in Format > Braille > Mathematics.

2.19. Inserting Literal Braille
• To insert Braille characters in the document that will be rendered identically in the Braille edition and

the print edition, the transcriber has two possibilities.

• In the dot pattern entry mode, Braille strings are specified by their dot patterns, e.g.
12-1235-1-24-123-123-15 ("braille" in uncontracted English Braille).

• In the six-key entry mode, users can insert characters with the keys S (dot 3), D (dot 2), F (dot 1),
J (dot 4), K (dot 5) and L (dot 6), as if they were using a mechanical embosser such as the Perkins
Brailler. So to insert "braille", type D+F, S+D+F+K, F, D+J, S+D+F, S+D+F, F+K. Spaces are
entered with the spacebar as usual and the enter / return key generates a hard return without starting
a new paragraph.

Note

Not all keyboards support this feature!

These modes can be activated in the menu Insert > Braille Characters.

2.20. Braille-only Material
• Text can be formatted such that it will only be rendered in the Braille edition of the document, but not

in the print edition.

• To insert non-printing text, go to Insert > Fields > Other… > Functions > Hidden text.

• To insert a non-printing paragraph, go to Insert > Fields > Other… > Functions > Hidden Paragraph.
In the Condition field, enter TRUE.

You can highlight these fields by checking View > Field Shadings.

http://wiki.services.openoffice.org/wiki/Documentation/OOo3_User_Guides/Math_Guide
http://wiki.services.openoffice.org/wiki/Documentation/OOo3_User_Guides/Math_Guide
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2.21. Hyphenation
• The user can choose to split words at the end of Braille lines if they are too long. This will improve

the layout of paragraphs. To enable hyphenation, check the corresponding box in Format > Braille >
General.

• For most languages, odt2braille has a hyphenation dictionary for automatic breaking of words. In
addition, a word at the end of a Braille line is always split when it contains a hard hyphen, i.e. a plain
minus sign ( - ). This allows for manual hyphenation. A more elegant solution is to use soft hyphens,
which are not brailled when the word appears in the middle of a Braille line. To insert a soft hyphen, go
to Insert > Formatting Mark > Optional Hyphen. They are only visible in OpenOffice.org when View
> Field Shadings is checked.

Note

Soft hyphens can only be used in Windows and MacOS.

2.22. Templates
• When you use the same Braille settings and layout frequently, it may be a good idea to store these

settings and layout in a template. Simply save your document as ODF Text Document Template (.ott).

• odt2braille also includes some predefined, real handy Braille templates. One for a simple Braille
document and one for a more advanced, multi-volume Braille document. Both templates contain a
preliminary section with a titlepage. You can find them under File > New > Templates and Documents
> Templates > Braille Documents.

3. Embossing Braille
To print a document on a Braille embosser, call the Emboss… window from the File menu, right beneath
Print….

• Select your embosser from the dropdown list. If your embosser is not supported, please contact
us and we will add it if possible. You can request features at http://sourceforge.net/tracker/?
func=add&group_id=330251&atid=1385420.

• Check that your embosser is powered on and loaded with paper. Specify the paper size in the dialog. If
the paper is not in the list, define a "Custom" paper size.

• Depending on the type of embosser, you can choose between single- or double-sided printing, and
between a 6- or 8-dot matrix. In addition, some embossers have special features like Character set
selection, Magazine style and Z-folding.

• Finally, set the margins.

Pressing the Emboss button will trigger the transcription process. When the document is succesfully
translated, you are given the option to "Preview" the Braille output before printing, or go on and print the
document immediately.

http://sourceforge.net/tracker/?func=add&group_id=330251&atid=1385420
http://sourceforge.net/tracker/?func=add&group_id=330251&atid=1385420

